Illustration: Unauthenticated RCE in React Server Components has patches available
React Server Components · Disclosed

Unauthenticated RCE in React Server Components has patches available

· 1 min read

Critical flaw GHSA-xqc2-xf4c-x3h3 in react-server-dom-webpack, react-server-dom-turbopack and react-server-dom-parcel allows unauthenticated remote code execution via crafted RSC Flight payload responses, according to Upwind. Fixes exist in 19.0.9, 19.1.10, 19.2.9 and 19.3.1, or via Next.js 16.4.1 or 15.5.28. Upwind recommends upgrading immediately; the source reports no active exploitation or public PoC.

WhatsApp LinkedIn X
HighVulnerabilityDisclosedPatched
In this article
  1. What happened
  2. Why it matters
  3. What to do
  4. For the technical team
  5. Timeline
  6. Sources

What happened

A critical flaw (GHSA-xqc2-xf4c-x3h3) in React Server Components packages lets remote attackers run arbitrary code on servers without any credentials. The attack uses malicious RSC Flight payload responses. Upwind disclosed the alert and calls for immediate upgrades.

Incidents like this, every morning

The ones that need action first, in a 3-minute read.

Free · 1 email a day, in the morning · no spam, unsubscribe in 1 click

Why it matters

Applications using react-server-dom-webpack, react-server-dom-turbopack or react-server-dom-parcel in versions 19.0.0 through 19.3.0 are exposed to full remote server takeover. That can mean data theft, operational downtime and infrastructure compromise.

What to do

Upgrade immediately to 19.0.9, 19.1.10, 19.2.9 or 19.3.1, or to Next.js 16.4.1 or 15.5.28. Identify today which systems use the affected packages and at what version.

For the technical team

Affected
React Server Components (pacotes react-server-dom-webpack, react-server-dom-turbopack e react-server-dom-parcel) · react-server-dom-webpack, react-server-dom-turbopack and react-server-dom-parcel in versions 19.0.0–19.0.8, 19.1.0–19.1.9, 19.2.0–19.2.8 and 19.3.0.
Exploitation
Disclosed by Upwind; the source reports no active exploitation, public PoC or KEV listing.
Fix
Upgrade to 19.0.9, 19.1.10, 19.2.9 or 19.3.1; alternative via Next.js 16.4.1 or 15.5.28.
Vector
Components react-server-dom-webpack, react-server-dom-turbopack and react-server-dom-parcel. Arbitrary code execution flaw exploitable remotely and without authentication, via crafted RSC Flight payload responses transporting multiple typed arrays and attacker-controlled values.
More details
Identifier GHSA-xqc2-xf4c-x3h3, rated critical by Upwind. Single source: Upwind alert (@UpwindMDR). No dates, IOCs or attack chain details cited.

Timeline

  1. Upwind advisory discloses the flaw and urges immediate package upgrades.

Sources 1 source

Get the next one tomorrow morning

One email a day with what changed, what to fix first and how. After signing up you get the full feed.

Free · 1 email a day, in the morning · no spam, unsubscribe in 1 click

Share it with your team

Whoever handles security with you should get it too.

LinkedIn X

Your colleague gets a confirmation request. Nothing is sent unless they confirm.

See all news

Read also

Before you go: get this every day

The HIFY Radar daily edition lands every morning with the incidents that need action. Free.

Free · 1 email a day, in the morning · no spam, unsubscribe in 1 click